Übersicht
In einigen Fällen kann es vorkommen, dass legitime Anfragen an Ihren DynDNS-Server von der Web Application Firewall (WAF) ModSecurity blockiert werden. Dies geschieht häufig aufgrund von ungültigen URL-Kodierungen in den Zugangsdaten, insbesondere im Passwort. Dieser Artikel erläutert die Ursachen dieses Problems und bietet Lösungen zur Behebung.
Symptome
- HTTP-Statuscode 403 Forbidden: Anfragen an den DynDNS-Server werden mit einem 403-Fehler abgelehnt.
- DynDNS funktioniert nicht, oder gibt den Fehler 0 zurück im Router Log.
- Die IP wird nicht aktualisiert.
Beispielhafte Log-Einträge:
2024-10-13 11:34:12 Error 127.0.0.1 403 GET /?username=waesrdtgf&password=dezfy%1uaJdgQdT!486 HTTP/1.1 SSL/TLS-Zugriff für Apache...
ModSecurity: Access denied with code 403, [Rule: 'REQUEST_URI' '@validateUrlEncoding'] [id "210381"] [msg "WAF: URL Encoding Abuse Attack Attempt||dyndnserver.de|F|4"] ...
Ursache
Die ModSecurity-Regel 210381
überwacht die URL-Kodierung von Anfragen. Wenn ein Passwort oder ein anderer Parameter eine ungültige Kodierung enthält, wird die Anfrage als potenzieller Angriff eingestuft und blockiert.
Beispiel für ein problematisches Passwort:
dezfy%1uaJdgQdT!486
Hier führt das %1u
zu einer ungültigen URL-Kodierung, da %
immer von zwei hexadezimalen Zeichen gefolgt werden muss (z.B. %20
für ein Leerzeichen).
Lösung
1. Passwort ändern
Verwenden Sie ein Passwort, das keine ungültigen URL-kodierten Zeichen enthält. Vermeiden Sie insbesondere das %
-Zeichen.